Se você é usuário mac e é desenvolvedor, deve usar o brew como gerenciador de pacotes. Nesse post vou mostrar como é simples controlar as suas versões do PHP usando esse gerenciador.

Primeiro valos instalar uma versão do PHP:

brew install homebrew/php/php70

Se você ja possui uma versão do PHP ele pode dar um error pedindo para que você faça um unlink na versão atual:

brew unlink php56

Esse comando deve deslinkar a versão 5.6 que era a que estava instalada no meu caso. Nesse momento mais um problema pode acontecer, é possível que você não tenha permissão para efetuar essa operação.

Para resolver o problema de permissão do homebrew usamos o comando chown:

sudo chown -R "$USER":admin /usr/local

Pronto, agora que estamos sem uma versão padrão do PHP, podemos tranquilamente fazer a instalação de qualquer versão usando o primeiro comando apresentado no post.

Para mudar de versão do php podemos fazer o seguinte:

brew unlink php70
brew link php56

php -v
PHP 5.6.26 (cli) (built: Sep 25 2016 21:03:19) 
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies